Loading...
 
Features / Usability

Features / Usability


Different sections

posts: 17

Hi!
How it is possible to create different site (vortal/portal) sections in one TikiWiki with various paths? For instance, I have main section at http://test.org/tiki-index.php about cats, and I want to create section for dogs at http://test.org/dogs/ with other articles, menus.

Greetings

posts: 1092

For now, usually, we use MultiTiki and we share user information between them (InterTiki is a new dev)
Not the best , but ...
sylvie


posts: 17

> For a multitiki like the one you say for dogs (as subdirectories), you'd like to give a read to:
> http://tikiwiki.org/tiki-index.php?page=AkiraMultiTiki

I'm a beginner... I have a apache, mysql etc. on my local WinXP.
I had putted this into my httpd.conf:

Image
Alias /tiki-test1 "c:/usr/krasnal/www/tikiwiki/tikiwiki/"
<Directory "c:/usr/krasnal/www/tikiwiki/tikiwiki/">
       Options Indexes
       AllowOverride None
       Order allow,deny
       Allow from all
</Directory>


but the installation haven't loaded neither with: http://localhost/~tikiwiki/tiki-test1/tiki-install.php nor "~tikiwiki/tikiwiki/tiki-test1/tiki-install.php". "tiki-test1" folder is empty.
where I made a mistake?

oh, and I can't execute any shell scripts, for example:

Image
# ./setup.sh apache apache 02755 tiki-test1 tiki-test2 tiki-test3

what exactly is doing the command mentioned above? Is another way to do this on my localhost?


posts: 1817 Catalan Countries

Seems that you're missing the first part of the apache alias at httpd.conf

See InstallTiki guides on windoze systems...

(and if needed, read also ftp install -> this will epxplain you what is done by setup.sh, and thus, what do you need to do by hand)...

Good luck.

Xavi

posts: 17

> Seems that you're missing the first part of the apache alias at httpd.conf
>
> See InstallTiki guides on windoze systems...
>
> (and if needed, read also ftp install -> this will epxplain you what is done by setup.sh, and thus, what do you need to do by hand)...
>
> Good luck.
>
> Xavi

Thx, I have already fixed up that. :-)


posts: 17

for some reason i have blank page now with AkiraMultiTiki mod. (yesterday everything was good) I have red in comments:

"ssigned a variable $url = getenv("SCRIPT_URL"), and put that one into the funtion"

please write a modified code of local.php, because I have no idea how it should looks.


Upcoming Events

No records to display

Menu