Loading...
 
Architecture / Installation

Architecture / Installation


Migrate 2.2 to new 3.0 site - error in the database query!

posts: 35

For safety reasons, instead of upgrading my 2.2 site to 3.0, I've created a fresh new 3.0 site, made an export of my 2.2 database in phpadmin and imported it into the new 3.0 site.

It all seemed to work, but after loging on I get the message: "error in the database query".

I thought the database hadn't changed between the 2.2 and 3.0 version. Does this error mean I have to use the upgrade script?

So would it be better to make a new install of 2.2 version first, then import the dump to this new 2.2 site and then use the upgrade script to upgrade it to 3.0?

Or, is there a quicker/better way to get rid of the error?

Suzanne
(www.vinidelmondo.nl/tikiwiki)

posts: 1817 Catalan Countries

Hi Suzanne:

You did very well with your procedure. You only need to run the tiki-install.php, which will let you choose between installation (no) and upgrade (yes, you need that, in order to have your database upgraded between 2.x and 3.0', where tehre are thousands of sql queries needed for the upgrade, afair).

By the way, could you please read to documentation about Upgrade2to3 and see the list of changes (linked from here, for instance: tiki3 ).
You are warned to read it, otherwise you might find more issues if you don't take the advice about themes styles changed, etc.

HTH smile


posts: 3
I got upgrading problems as well. but then with the script but get 51 query errors and cant use anything, it is in a older topic i posted.

posts: 1817 Catalan Countries

add url if possible or more details, SirDude0Lot
or request help on Irc if urgent


posts: 35

I tried again and did it step by step (2.2 to 2.3, 2.3 to 2.4, 2.4 to 3.0). No more query errors.
Just one single newsletter (pdf) that caused problems, I removed it from the datadump.

I did ran into another slight (not tiki3-related) problem concerning characters with accents (I initially lost them all), but solved that with bigdump. Although it looked like the database had exported to latin1 (phpadmin), it actually proved to be utf8. Took me a while to figure this out...

So, everything is fine now.

Suzanne


posts: 35

I seem to have the same problem againquestion
A few weeks ago I've exported my db from the old to the new site and managed to upgrade it to 3.0. So, i had 3.0 running with a copy (and upgrade) of my old database.The old site was still live and I've upgraded it from 2.2 to 2.3 and from 2.3 to 2.4. So, the old site was already on version 2.4.

I now need to import and upgrade my old db again so I can disable the old site and switch over to the new site.

So, i wanted to export the 2.4 db, bring it to the 3.0 site and upgrade the db to 3.0. I used bigdump (and the same script as last time), imported the database (everything was fine), I upgraded to 3.0 (everything still looked fine - no errors). After entering Tiki I got the same error: error in the database query on every page.

So, my entire new site is broken.

Did I overlook something????

Hope someone can help, I don't have a clue what's wrong now...

Suzanne

posts: 4644 Japan

What, specifically, is the error that's being reported? That will give clues about what needs fixing.

-- Gary


posts: 35

The problem is caused by bringing the 2.4 database to the new 3.0 site and then upgrading the database to 3.0.

Last time, when my old site was still in 2.2, I've made a new 2.2 site. Exported the database and imported it in the 2.2 site and then used the 2.2 to 2.3 script, the 2.3 to 2.4 script and the 3.0 upgrade script.
That went allright.

Now when trying to upgrade the 2.4 database in the 3.0 site, the upgrading goes ok (no errors there), but when entering the site I get the following error on every page.

" error in the database query"

Message:
Built query was probably:"


It's not possible to paste the error in a CODE. It gets destroyed.

I think i can solve this by installing a new 2.4 site from scratch, then export and import my 2.4 database into this 2.4 site. Then copy all 3.0 files over the 2.4 site, then upgrade the db to 3.0. But, this is quite a long way...

Suzanne


posts: 4644 Japan

You can paste the error message here: http://pastey.net/. Paste the error message in the box, put your name (any name) in the author box and, after submitting, post the url here. I think that should work.

-- Gary


posts: 35

I solved the problem as follows:

create a new 2.4 site
export my 2.4 database (old site)
import 2.4 database in 2.4 site (using bigdump)
copy 3.0 tikiwiki files over 2.4 site
upgrade 2.4 site and database to 3.0

As it seems it is not possible to import a 2.4 database to a 3.0 site and then do the upgrade.

Suzanne