Features / Usability

Features / Usability

Admin mods - Install mods

posts: 15 Norway

I have Tikiwiki 1.9.4 on a remote site. I am trying to get the list of mods to be updated. This worked fine on my local installation (, but I don't remember whether I first chose "update remote list" then "rebuild local list" or not, but I have tried both with the 1.9.4 version and nothing works. I think I have the correct priveleges since I am presented the following message:

Apache has the right to write in your file tree, which enables the installation, removal or upgrade of packages. When you are done with those operations, think to fix those permissions back to a safe state (by using "./fixperms fix" for example).

I do, however, notice that when I choose "update remote list" that I get the following message:

Invalid remote file on url "http://tikiwiki.org/mods/Packages/00_list.public.txt".

I can go to this file, so it's not that the file does not exist. Maybe some incompatible changes have been made from to 1.9.4.

I also tried to copy over the files from from installation to the 1.9.4 installation. I got a list of mods then, but then the "install" tikidav mod failed (something about they key exceeding the maximum 1000). So, I rolled everything back. I was able to install the tikidav mod on my local installation, but I do not have my local server set up properly for webdav and thought I would test it out on the remote server.

My goal is to install Tikidav so that I can try out the OpenOffice integration. I am thinking about using Tikiwiki with my high school students this fall and we are considering starting out with OpenOffice instead of Microsoft Office this year. Also, I am not pleased with the spellcheck function in Tikiwiki and read that the Tikidav mod was the solution. This looks great in the video about how to do this.

Sorry for the long-winded story. I hope someone can help me out.


posts: 1817 Catalan Countries

Hi Diana:

"Admin Mods" worked fine for me (tried just now, after readuing your post). Using 1.9.4 on GNU/Linux server.

Go to "Admin mods > mods configuration"
I have it set as:

Enable Mods providing : [ ]
Mods local directory: mods
Mods remote server: http://tikiwiki.org/mods


Then go to "Mods Install/Uninstall", and select "update remote index"
This worked for me. Then I you select installing tikidav (unistalling previous version, if needed).

Ask again if in trouble. Tikidav author is also on edu.tw.o ...

However, there are already detected some errors under this tikidav release... (see this post)



posts: 15 Norway

Thanks Xavi for replying so quickly.

Unfortunately, I was not able to get the remote update list to work. But, I decided to download the tikidav mod from the repository and place the 2 folders (features and packages) in the mods folder for my installation. When I then chose "rebuild local list" then the tikidav mod showed up in the list. Not sure if that is the correct way to do this, but...

In any case the problems did not end there. When I select "install" I get an sql error. I must say the create table script is very unusual. I don't know if you work with sql very much or not, but I get the following:

An error occured in a database query!

File /tikiwiki-1.9.4/tiki-mods.php
Url /tikiwiki-1.9.4/tiki-mods.php?action=install&package=features-tikidav
CREATE TABLE `tikidav_locks` (`token` varchar(255) NOT NULL default ,`path` varchar(200) NOT NULL default ,`expires` int(11) NOT NULL default '0',`owner` varchar(200) default NULL,`recursive` int(11) default '0',`writelock` int(11) default '0',`exclusivelock` int(11) NOT NULL default '0', PRIMARY KEY (`token`),UNIQUE KEY `token` (`token`),KEY `path` (`path`),KEY `expires` (`expires`),KEY `path_2` (`path`),KEY `path_3` (`path`,`token`)) TYPE=MyISAM;
Error Message Specified key was too long; max key length is 1000 bytes

I read up on this and found the following:

This is not a bug, it is a stated limitation. From the manual page:

"Prefixes can be up to 255 bytes long (or 1000 bytes for MyISAM and InnoDB
tables as of MySQL
4.1.2). Note that prefix limits are measured in bytes, whereas the prefix length
statements is interpreted as number of characters. Take this into account when
specifying a
prefix length for a column that uses a multi-byte character set."

You are correct, it is the utf8 that is causing the extra bytes.

I took a look at my local installation where I accidentally set up the db with "latin1_swedish ci" collation which for some reason is default (I guess since I have a Norwegian OS and keyoboard). I had no problem running the sql script probably because I didn't use utf-8. But, as I said I think it is a very strange table structure and so does php myadmin:

Warning PRIMARY and INDEX keys should not both be set for column `token`
Warning More than one INDEX key was created for column `path`

I don't know if I will be continuing with this project right now. School just let out for summer, and here I am getting bogged down in new problems, and problems that I don't get paid to solve. Ha, ha!

I could try to change the field properties to lower byte values and see if that helps, but I'm may just be setting myself up for problems in the future. It's strange that it doesn't work especially since the intallation instructions suggest that the db be set up with utf-8. Maybe they are using a new version of mysql.

Now that I have read about your problems, I doubt whether I will put in too much more time into this unless someone can give me some suggestions. Otherwise, I'll just be wasting a couple of more hours. I wonder how they got it to work so nicely at www.escire.com?


posts: 1817 Catalan Countries

Hi Diana.
I'm sorry to see the problems reported. I have no idea myself, about what or where is the problem. It worked for me strait ahead from admin mods web interface, on one server, and on another, where there is a strange perms. configuration, we couldn't through we interface, and I ended up installing it by hand (as you did, btw :-).

Being said this, I had to request to the server admin to install some module (bablotron, as far as I remember) for tikidav to work. But once that was installed, tikidav works (taking into consideration that's not a finished work by his author, jreyes).

I would say, write to the author directly (he might not be reading this forum), and he's rather busy, but he'll end up answering you, for sure (and maybe fixing this problem for you?). jreyes at escire.com

Cheers, and good luck!


P.D: I hope you've seen AulaWiki and try it for your educational purposes (I'm planing to use it for production next course with some of my students also)

posts: 1817 Catalan Countries

Btw, Diana, read the readme.txt (or similar, I don't remember exact name) which is inside zipped file. There it says what you need to have installed in the server (if not available yet), and what you need to have copied inside the .htaccess file of your tiki root directory.

I guess that installing through admin mods interface, these notices are not seen by the user....

I'll report jreyes myself about this issue.