Loading...
 
Features / Usability

Features / Usability


Can see but not click Quicktag buttons in editor.

posts: 8

I'm just rewording this post to make things more clear.

If I open a Wiki page and click Edit, the quicktag buttons for formatting (bold, italics, bullet list, etc.) seem to do nothing. I click in the text area where I want the code to go, I click one of the quicktags, and the focus shifts out of the text area and nothing else happens. No javascript errors at the bottom or anything.

HOWEVER, If I click edit and then Preview, or Fullscreen Edit, the quicktags work fine. If I exit Fullscreen Edit back to the default editor, the quicktags continue to work fine. If I save and then edit the page again, quicktags are once again broken unless I first preview or use fullscreen edit first.

This is happening on 5 computers running everything from Windows XP to Windows 7, in both IE and Firefox. Javascript is enabled, as proved by the fact that it works fine, just not in the initial edit screen.

I was using v2.2 when this began, cleared cache, upgraded to v2.3 and then v2.4 and did the upgrade stuff, cleared cache again, etc. I tried running a file check but it just drops to a blank screen after a while, and yes I changed php to a longer timeout.

I did make some configuration changes but none of them should have anything to do with this, and I've since gone through and reversed any changes I can recall and have been looking for others with no luck. I'm completely stumped.

posts: 1817 Catalan Countries

did you also clear your browser caches?
Did you try with other theme styles?

posts: 8

I didn't clear my browser cache, but I did try it on 2 different computers and 2 different browsers and it did the same thing. This morning I came to work and tried it on our XP workstations in IE, as well as my Vista laptop in Firefox and it's doing the same thing.

Click, text area loses focus, no code appears. Unless I click the full-screen edit mode, and then go back to regular mode, then it works fine. I will try another theme this morning too.

/edit tried another template, and it does the same thing.


posts: 8

I know Javascript works. I tried this on FOUR different computers in 2 different web browsers.

The only buttons in the quick launch that work are the fullscreen edit and admin quicktags buttons. When I click the "fullscreen edit" button, the quicktags work. When I click "Exit Fullscreen" and go back to the regular screen, the one I started with after I initially hit Edit, the quicktags work.

It's only when I click Edit and then a quicktag that nothing happens. The wysiwyg editor does not have these problems.


posts: 8
This is driving me bonkers. I can't find a single thing that could cause this. I'm baffled by the fact that going into fullscreen edit makes it work, as does exiting fullscreen edit.

posts: 9

Hello,

I have the same trouble. New Page no problems, only edit a old page i must switch to full screen and back then Quicktag works. I use Tikiwiki 2.4 with Tikipedia. And I have another problem, after edit a page and save it I became HTTP Error 500 and I must refresh the site and sometimes I must start new.


Norbert

www.freizeitguide24.de


posts: 8
It sucks to see someone else with the same problem, but I'm glad I'm not just crazy :P