Loading...
 
Features / Usability

Features / Usability


Re: Your email could not be validated

posts: 1817 Catalan Countries

commania: you'd better upgrade to the latest 2.x tiki for your own security (2.4 currently)
see doc:Upgrade