Loading...
 
Architecture / Installation

Architecture / Installation


v3.3: Error in tiki-install.php

posts: 2

Hi,

I tried to do a fresh install of tikiwiki-3.3 before upgrading tikiwiki-1.9.9. However, when going to http://localhost/tiki/tiki-install.php i only get a blank page and /var/log/httpd/error_log shows:


Thu Jan 07 09:23:12 2010 notice Apache/2.0.54 (Fedora) configured — resuming normal operations
client 10.42.42.247 PHP Parse error: parse error, unexpected T_ARRAY, expecting '&' or T_VARIABLE in /var/www/html/tikiwiki-3.3/lib/core/lib/DeclFilter.php on line 20
client 10.42.42.247 PHP Parse error: parse error, unexpected T_ARRAY, expecting '&' or T_VARIABLE in /var/www/html/tikiwiki-3.3/lib/core/lib/DeclFilter.php on line 20



I have checked file permissions and php mem settings. Any ideas?

Current Versions:
tikiwiki-3.3
httpd-2.0.54-10.4
php-5.0.4-10.5
php-mysql-5.0.4-10.5
Fedora Core release 4

Best regards,
John

posts: 1817 Catalan Countries

John, welcome to Tikiwiki Community!
And ensure that your web server has at least 32 Mb of memory_limit at the php.ini
See the Requirements of Tiki, if needed.
HTH


posts: 2

Hi, and thanks for a quick reply!

Sorry, but that's not it. I had already set the memory limit to 64 Mb and restarted the httpd service.

% grep memory_limit /etc/php.ini
memory_limit = 64M ; Maximum amount of memory a script may consume (8MB)

As far as I can see, all requirements are met (Ref. versions listed in first posting). What else should I check / try ?

Best regards,
John


posts: 1817 Catalan Countries

Hi John, try (just in case) rising memory_limit to 128 Mb. I have a site with many galleries, files, users, and permissions set, and it takes sometimes more than 64 Mb :-/ (65Mb in my case)

Yes, devs seem to be aware of this issue obn big sites. So just in case, 64 Mb is not the final proof, unluckily. :-)


posts: 1817 Catalan Countries
oups, sorry, my mistake, you said it was in the blank tiki, not the upgraded existing one. No idea myself, then. sorry

posts: 1

Hello!

The same problem on blank tiki.. tiki-install.php
I see only this message:

Parse error: syntax error, unexpected T_ARRAY, expecting '&' or T_VARIABLE in ..\lib\core\lib\DeclFilter.php on line 20

Any ideas?