Loading...
 
Features / Usability

Features / Usability


Tracker form - text fields not displaying

posts: 84

Tiki 5.x. I've created a tracker, then used the tracker plugin in a wiki page to display a tracker form. The date filed and the country selector fields work, but my text fields and textarea field don't display, even though their description does. I do have the field set to public y and not hidden.

Can you offer any help?

posts: 1817 Catalan Countries

Hi brandanhadlock:

Copy & paste here (surrounded by CODE plugin, the contents of your TRACKER plugin call, and if possible, provide more details (or screenshot) of the edit fields page.

posts: 84

Here is the plugin call:

{TRACKER(trackerId="2" fields="12:13:14:15:16:17:18" action="Shout Out!" showtitle="n" showdesc="y" showmandatory="y" embedded="n" preview="Preview Your Shout Out")}Thanks for shouting out and promoting the good! Now let your family and friends know that you've complimented someone. {TRACKER}



Attached is a screen shot of the form page. I'll also post screenshots of an edit field page.



posts: 1817 Catalan Countries

mmm, I can't see the definition of all your fields.

Could you screenshot the table of the fields , and not just one by one?

12:13:14:15:16:17:18

So similar url, but for the first "tab".
It looks as if there is some selection at the "Field is hidden" of option which restrict access to the user... (only viewable or editable by admin, and not the user... (just a guess)


posts: 84

I tried putting the screenshots in a word document. Let me know if this gives you the views you need. On the headline field (12) I selected a bunch of groups to see if that would make a difference. It didn't. On the tracker itself, I also tried having the field "Do not show empty fields in item view" unchecked, but that didn't make a difference.

My registration tracker works, but that originally came with the profile. Haven't figured out yet why I can't get a fresh from scratch tracker to work.

Thanks for looking at this.


posts: 1817 Catalan Countries
where is that word document?

posts: 84
I figured it out. There must be a bug in the system. If "multilingual content" is marked for the tracker field, the field will not show.