Loading...
 
Features / Usability

Features / Usability


Need some help with jquery

posts: 10

I'm having a little trouble with Jquery and trackers.

I have been trying to use jquery to pre-fill some fields, but it only seems to work with text areas.
Below is the code that I put in a wiki page along with the tracker plug in. Wile the area_681 line works fine, the track_673 dose not.

{JQ()} $jq("#track_673").val("6.25"); $jq("#area_681").val("line 1\nline 2\nline 3"); {JQ} {TRACKER(trackerId="41",fields="701:671:672:673:674:675:676:677:678:679:680:681:682:683:684:685:686:687:688:689:690:691:692:693:694:695:696:697:700:698:699",showtitle="y",showdesc="y",showmandatory="y",newstatus="op")}{TRACKER}

track_673 is a simple text field line, wile area_681 is a textarea. I followed the instructions in http://doc.tiki.org/PluginJQ but is till can't make it work.

Please tell me someone can help.

P.S. we are running Tiki 3.8 one PHP Version 5.2.9 (Apache 2.0 Handler)

posts: 1817 Catalan Countries

Hi elawrence and welcome to Tiki Community!

I'm afraid that what you are trying is probably only working in Tiki 5.x and 6.x, at least (where I tested it; I wrote most of the PluginJQ examples, with the expertise from jonnyb and robertplummer.

You can try on Irc if you have further questions on JQuery.

And please, help us to improve the tips in PluginJQ as you learn more things with Jquery! :-)

Cheers

Xavi


posts: 1817 Catalan Countries

Since Tiki6 RC1 is released (and 6.0 will be released soon), I suggest that you try testing an upgrade (after you backup your db first, of course) to 6.x
See Upgrade and specially, follow carefully the steps in "Fix_the_encoding_issue".

Cheers


posts: 10

Thanks for the advise. I guess I'll just hold until Tiki 6.0 is released.

We use Tiki as our company's Intranet and IT will not sign off on installing a beta. So I'll patiently wait for 6.0 biggrin

P.S. I want to thank all the developers of this project. Tiki has solved just about every problem that my boss has thrown at me.


posts: 10

Ok I'm back.. (LOL)

So we finally installed TW6 and it's great..... BUT...

I'm still having a little bit of trouble with JQ.

I'm now trying to do "Conditional display of fields" and it works great as long as the field I'm hiding is a text or numeric field. I can;t get it to hide static text, text areas or other drop downs.

I would greatly appreciate if someone can point me in the right direction.

Thanks is advance

p.s. I attached a .txt file with the code as I placed it in the wiki page.

Text area is field #22,
Static is field #20
drop downs are #25 and #29.