Architecture / Installation

Architecture / Installation

13.1 to 14.0 Upgrade - Blank pages

posts: 34

I upgraded successfully, overwriting the htdocs folder.

I have a separate login page which comes up fine, but any other pages appear just blank...I view the source and see this:

<!DOCTYPE html>
<html lang="en">
<!--Latest IE Compatibility-->
<meta http-equiv="X-UA-Compatible" content="IE=Edge">

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="generator" content="Tiki Wiki CMS Groupware - http://tiki.org">


	<meta name="robots" content="NOINDEX, NOFOLLOW">

<title>ITSM KB | Pages</title>

	<link rel="icon" href="favicons.png">

	<link rel="alternate" type="application/rss+xml" title='RSS feed for articles' href="tiki-articles_rss.php?ver=5">
	<link rel="alternate" type="application/rss+xml" title='RSS feed for forums' href="tiki-forums_rss.php?ver=5">


<!--[if lt IE 9]>
	<script src="vendor/afarkas/html5shiv/dist/html5shiv.min.js" type="text/javascript"></script>

<link rel="stylesheet" href="themes/base_files/css/tiki_base.css" type="text/css" />
<link rel="stylesheet" href="vendor/fortawesome/font-awesome/css/font-awesome.min.css" type="text/css" />
<link rel="stylesheet" href="themes/default/css/default.css" type="text/css" />
<link rel="stylesheet" href="vendor_extra/elfinder/css/elfinder.full.css" type="text/css" />
<link rel="stylesheet" href="vendor/codemirror/codemirror/lib/codemirror.css" type="text/css" />
<link rel="stylesheet" href="lib/codemirror_tiki/codemirror_tiki.css" type="text/css" />
<link rel="stylesheet" href="temp/public/codemirror_modes.css" type="text/css" />
<link rel="stylesheet" href="vendor/jquery/jquery-ui-themes/themes/flick/jquery-ui.css" type="text/css" />
<link rel="stylesheet" href="vendor/jquery/jquery-timepicker-addon/dist/jquery-ui-timepicker-addon.css" type="text/css" />
<link rel="stylesheet" href="vendor/jquery/plugins/colorbox/example1/colorbox.css" type="text/css" />
<link rel="stylesheet" href="vendor/jquery/plugins/treetable/stylesheets/jquery.treetable.css" type="text/css" />
<style type="text/css"><!--
/* css 0 */
@media (min-width: 1200px) { .container { min-width:1000px; } }
.ui-autocomplete-loading { background: white url("img/spinner.gif") right center no-repeat; }

<!--[if lt IE 7]>
<link rel="stylesheet" href="themes/base_files/feature_css/ie6.css" type="text/css" />
<!--[if IE 7]>
<link rel="stylesheet" href="themes/base_files/feature_css/ie7.css" type="text/css" />
<!--[if IE 8]>
<link rel="stylesheet" href="themes/base_files/feature_css/ie8.css" type="text/css" />
<!--[if IE 9]>
<link rel="stylesheet" href="themes/base_files/feature_css/ie9.css" type="text/css" />

	<script src="respond.min.js"></script>

		<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<body class=" tiki tiki_wiki_page manage fixed_width  layout_basic">

					<div id="ajaxLoading">Loading...</div>
<div id="ajaxLoadingBG">&nbsp;</div>
<div id="ajaxDebug"></div>

		<div class="container">
			<div class="page-header">
                <div class="top_modules">

Thats it, same on every page.

I also tried removing all the old files and creating a new htdocs folder for this installation specifically. Same issue. Any ideas?


posts: 34

I just tried installing by competely rewriting and creating a new DB, this worked so the problem must be something to do with the current DB for 13.1

I also tried importing the old database after I had recreated it with the installer, same ting, all pages balnk and source the same as above.

posts: 34

I fixed it, I suppose the clue was in "top_modules" being the last thing tiki rendered.

I have a moule for live support that is obviously not supported in 14.

Removed this, all working.

Upcoming Events

No records to display