Features / Usability

Features / Usability

Everything lost ? Big mystake in admin config...

posts: 36

After 2 weeks of very hard work with little or big problems (the biggest was always solved here by you all, thanx), I was ready to put my site on the net, officially... but... :'-( it seems I've made a big, big mystake during the last admin operation... and now it's totally impossible to access to the site or any configuration page...

I'm not sure what cause this but I was working on inserting google analytics code, facebook button and StatCounter code.

I was in teh admin area where there are 4 windows and a space where to write down the google analytics id number.

My error was, I think, to use the 4th window, mentionning to not write the script without the
indication. I copy/past, the 3 scripts and save. The I saw the code have been totally modified and saw in the same time that I probably should I have wrote all this in the 3rd window that is mentionning using the end of the body juste before it's end...

I try to do this modification but since (I think, but it's not sure, that my last modification hadn't time to be done in facts) I've no way to acces to any of the page (wiki, admin,...) of my site, my browser returning various error but total error always: nothing could be read, and no source page could be seen.
Here what I get with my 3 differrents browsers:

konkeror: Détails de la requête :

Adresse : http://www.rx3.net/~lgibert/mtc-tiki/tiki-index.php
Protocole : http
Date et heure : mercredi 9 décembre 2015 05:55
Informations complémentaires : Internal problem of the server

Firefox: a white page with only, in the source code, the number 1 on the top left

chromium: The site encountered an error during extraction of http://www.rx3.net/~lgibert/mtc-tiki/tiki-index.php this could be caused by incorrect configuration.

Please, help me to save my wiki pages at least... It was so much work...

I can naturally access to the entrire site by FTP, I take a look at one of the file (index) but saw nothing weird... in other hand I don't know exactly what is weird or not... :-/

If needed here is my site link

Thanx in advance...

Luc 'near 6 feet under...'

posts: 214

Hi Luc,

Don't panic.  You need to use phpmyadmin and access the "tiki_preferences" table.  You can edit the row with the problem and remove the problem code you entered.  Once the database is updated and you have done a Control/Reload in your browser, you will probably have everything back. 

If you search the forum you will find others have had similar problems.  Here is an old post I made trying to help someone else with this:


It is 1:00 am here and I really need to go to bed so I can't help much more now. The "admin area" you are referring to is the Look and Feel, Customization tab. 

Good luck,


posts: 36


Thanx for your answer.

But It's still impossible to access to my site...  :-(

I've searched the 4 lines in the table and didn't found at all feature_custom_html_head_content. is it normal ?

feature_endbody_code was containing my second code and is now empty (no y or n, just empty), but if this was filled, it means that my "correction" was saved just before shutdown... but... :-/

header_custom_css is empty

header_custom_js is empty

and i've deleted too site_google_analytics_account

But nothing good happens. The site is still unreachable, I've even tryed what you said: use another computer with another browser... but no, same result.

I take a look at the other line of pref but found nothing interessant... AFAIK. Or there is some cache I don't know where.


So I hope you have a good night and could help me again...  :-)

If you want, I can send you by mail access to my sql table.




Two new things:

- the script tiki-check doesn't function too, same error: blank screen. But works if I place it in upper directory.

- the log of the server tell that it's smarty process who is crashing. Here is the log:


Wed Dec 09 14:17:45.015013 2015 :error pid 31619 client PHP Fatal error:  Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "2a8327205720ceb3429ad6e2e3e60a05da2cd5eb"  on line 11 "window.___gcfg = {lang: 'fr'};"  - Unexpected ": ", expected one of: "}" , " " , ATTR' in /home/rx3/lgibert/public_html/html/mtc-tiki/vendor/smarty/smarty/distribution/libs/sysplugins/smarty_internal_templatecompilerbase.php:667\nStack trace:\n#0 /home/rx3/lgibert/public_html/html/mtc-tiki/vendor/smarty/smarty/distribution/libs/sysplugins/smarty_internal_templateparser.php(3144): Smarty_Internal_TemplateCompilerBase->trigger_template_error()\n#1 /home/rx3/lgibert/public_html/html/mtc-tiki/vendor/smarty/smarty/distribution/libs/sysplugins/smarty_internal_templateparser.php(3209): Smarty_Internal_Templateparser->yy_syntax_error(2, ': ')\n#2 /home/rx3/lgibert/public_html/html/mtc-tiki/vendor/smarty/smarty/distribution/libs/sysplugins/smarty_internal_smartytemplatecompiler.php(105): Smarty_Internal_Templateparser->doParse(2, ': ') in /home/rx3/lgibert/public_html/html/mtc-tiki/vendor/smarty/smarty/distribution/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 667



posts: 3661 United States

After you clear out the database tables, you'll need to manually clear the cached templates (look for the cache and template_c directories in your Tiki installation folder.

Then, clear your browser cache.

Then, you should be able to access your site.


- Rick  |  My Tiki Blog |  My Tiki UserPage

Why be a dummy? Get smarty! TikiForSmarties.com
Tiki for Smarties, your source for the best (and only) Tiki books, guides, and tutorials.
posts: 36

Thank you very much Tom and Rick!!! 


It seems my site is back!  :'-)  Youhouuu!!  It's X-mas no ? Well, soon! ;-)

Anyway, thanx for your help, panic mode wasn't really far... great, troubles gone.


In my strenght action of deleting what could be cache in my config, I ask myself if it was a good idea to delete in the same way:

- everything that was in the templates_c directory

- everything that was in the temp directory  and not only the under directory cache.


As I've made backup before deleting, I can replace them. What do you think about it ?



Upcoming Events

No records to display