Loading...
 
Features / Usability

Features / Usability


Error Generated When Clicking on Categories

posts: 706

When I click on a category in the right sidebar of our site at http://woodworkerswiki.org/tiki-index.php
we get an error code that looks like this, Error
Notice: invalid variable value: $_GET%22parentId%22 = 1deep=on
We are running Tiki 14.0 using Utopias theme.
Thanks for any help!

And I forgot to add we are using the Category Module in the right side of our site.

posts: 706
Site temporarily down. Link does not function. If anyone is interested in visiting this issue I can put the site back up. Thanks!
posts: 496

Hi

There is a problem how links are generated when "Search engine friendly URL"  (feature_sefurl) is turned off.

I take a look at this, in the meantime you can get category links working by enabling this feature (go to tiki-admin.php?page=features and turn on feature_sefurl)

cheers,

gezza

posts: 706
You are most awesome Gezza, thanks for the information! I'll implement this fix soon and get back with regarding if it was successful or not. Thanks for jumping in and giving me a hand!
posts: 496

i made a quick commit to the 14.x branch (r55599), hopefully it fixes it even when SefURL is off,

please update your site if you can and and test this, thanks,gezza

posts: 706
Will do Gezza, thank you! I am working on it now, I'll get back soon.

posts: 706
SIte is back up, with errors still if you wanted to see what I am seeing. Meanwhile I am working on the fix, thanks!

posts: 706

Gezza, I am sorry, I had not had a chance to implement your fix, but I did switch to SFURLs and it all works great now. I figure it's better to implement the sfurl anyway.

Thanks for your time on this Gezza!