Loading...
 
Features / Usability

Features / Usability


SEFURL missing?

posts: 6 Philippines

Hello together, most of my Problems i could solve some way or another by now.

When i started to create some new Categories it worked also fine, but why are Category URL's not SEFURL's?

I get
http://www.domain.tld/wiki/tiki-browse_categories.php?parentId=2&deep=off&type=
instead of what I had expected
http://www.domain.tld/wiki/category/CATEGORYNAME

I found that Problem when i was editing the Mainpage. I had no idea how to get it a bit more like Wikipedia with a Random Page or something. So i went to create something like a Category overview with some Description Text like:

Categoryname 1
Category 1 Description with some pretty Text.
Categoryname 2
Category 2 Description with some pretty Text.

The name should be with Link, but by now it seems a bit odd why i can't have the Categoies also as SEFURL?
Pages are clean shown as http://www.domain.tld/wiki/page+name
So yeah, the htaccess should be fine.

Any idea what is going on?

Kindly

posts: 3637 United States

The SEFURL for the default category browser is to use the category ID — not its name:

https://tiki.org/cat1

 

If you want to have a page with (with the category's name) that displays the items from the category,  you could:

  1. Create a new wiki page (as the name of the category)
  2. Use the CATEGORY plugin to display the items in the category.

This way, when you go to http://yourdomain.com/CATEGORY, you'll see the list of items in the category.

HTH,

- Rick  |  My Tiki Blog |  My Tiki UserPage

Why be a dummy? Get smarty! TikiForSmarties.com
Tiki for Smarties, your source for the best (and only) Tiki books, guides, and tutorials.