Loading...
 
Features / Usability

Features / Usability


Upgrading from 14.0 to 14.2 changes the behaviour of login

posts: 27 Indonesia

Hi:

I have a TW 14.0 and doing a test to upgrade to 14.2 found that the homepage behaves differently and does not show the login/password dialog any more.

On the TW14.0

  • Setup as Intranet. Anonymous users have no permissions
  • Tiki feature as homepage : articles
  • Ticked: On permission denied, display login module (for Anonymous)


so, when a users shows up to the homepage it has access denied (as it's still anonymous) and the homepage is /tiki-view_articles.php anf looks like this before logging in:

Homepage In TW14
when the user logs in she can read the articles. Perfect!

When I upgrade to 14.2 the same homepage /tiki-view_articles.php shows an information box "No articles Yet", but no login/password dialog as:

Homepage In TW142

We still want the Anonymous visitors completely out, and want to maintain the behaviour of 14.0 whenre a dialog for Username / password was shown to user. (besides the login messages on the right upper corner, but that's not very user-friendly).

How to maintain this functionality when upgrading to 14.2?

many thanks,
pak

posts: 1560

did anything change in tiki-admin.php/page=general or tiki-admin.php/page=login?

It looks like an unticked preference, where an upgrade should not untick preferences without clear admin consent.

Please check the login prefs


posts: 27 Indonesia

Hi Torsten:

Thanks for the hint, but as far as I can see settings are the exactly same settings.

In both cases (14.0 and 14.2) the home page is tiki-view_articles.php as expected. looks like it's just a different way of handling the "permission denied":

  • In 14.0 shows a warning and then I gues it gets redirected to login thanks to "On permission denied, display login module (for Anonymous) "
  • In 14.2 just shows an Information "No artciles yet", so it does not trigger the redirection to login page.


So I guess it's a different way of handling the permission denied between versions, but no clue if I'm on the right path.

Found a system to make it work but does not seem very elegant:
in tiki-admin.php?page=general

  • Use group homepages ticked
  • Use custom homepage ticked
  • Homepage URL = tiki-login.php
  • Use group homepages ticked

And in Admin groups, set tiki-view_articles.php as homepage for registered.

Would like to get a cleaner somution, as the one in 14.0 that was straight forward.

Thanks,
Pak

posts: 496

hello

I think it was changed on purpose by this commit: https://sourceforge.net/p/tikiwiki/code/55802

you can read the reasoning on that page

i dont really have an opinion on this, just letting you know :-)

cheers,
gezza

posts: 27 Indonesia

Thanks Gezza!

All clear then. will use the solution posted previously.

pak.