Loading...
 
 Error
  • Elasticsearch flush error: Validation Failed: 1: id is too long, must be no longer than 512 bytes but was: 944;2: id is too long, must be no longer than 512 bytes but was: 567;
 Error
  • The search index could not be updated. The site is misconfigured. Contact an administrator.
    Validation Failed: 1: id is too long, must be no longer than 512 bytes but was: 944;2: id is too long, must be no longer than 512 bytes but was: 567;
Features / Usability

Features / Usability


Do I have to write my own {TABLE} plugin for colspan and rowspan to work?

posts: 126803 United Kingdom

Hi FootlooseTraveller

Interesting and really good question!

Starting a new table plugin/syntax would certainly be an option (it's the "wiki way"), but i think it would be better to add new functionality to the existing wiki table syntax, and/or the {FANCYTABLE} plugins.

Doesn't this approach in fancytable almost do what you need already?

Another thought to bear in mind is that we have a long term goal to move to markdown eventually, as planned here WYSIWYG and Markdown, so maybe it's worth seeing how md does this? (if it does)