Loading...
 
Architecture / Installation

Architecture / Installation


Tiki10 -> 12 compatible with PHP 5.5?

posts: 103 Wales

Our server currently hosts various Tiki 10,11 & 12 and runs php 5.3.

We're planning to upgrade all Tiki installations to 13.

In advance of this we'll upgrade server to PHP to 5.5.

QUESTION:
Will the currently installed Tiki 10, 11 & 12 work fine on PHP 5.5 in the intermediary period before we then upgrade them to 13?

Cheers.

posts: 1560

Hi Dominic,

I sugggest to upgrade your Tiki10 and Tiki11 to Tiki12, as Tiki12 is LTS and 10 and 11 are not supported anymore.

Tiki12 works with PHP5.5. (The others I do not know, as I never stay for long between the LTS versions ... but I have a productive project of an NGO running on Tiki12 on a PHP 5.5 server)

Torsten

posts: 103 Wales
Thanks, Torsten.
posts: 1560

Dominic,
please do not forget to - under all circumstances - take a dump of the databases BEFORE ANY upgrade of a productive (or nearly ready to go) project, as you cannot downgrade a database!!!

Cheers,
Torsten


posts: 103 Wales
yes - good reminder biggrin