Loading...
 
Architecture / Installation

Architecture / Installation


DB Connection failed on install

posts: 3 USA

Windows 7 Home Premium SP1: Used latest xamp to install dependencies... (XAMP 5.6.3 / PHP 5.6.3 \ mySql 5.6.21, phpMyAdmin to 4.2.11, OpenSSL to 1.0.1j) and tiki-13.1.7z... had bookoo problems but resolved them all... used doc @ https://doc.tiki.org/Install+Tiki+on+XAMP... After 4+ hrs got to step 7 (tiki install) @ 'set the database connection' screen and got error 'Error Database `tiki`. Unable to connect to database'... rechecked all info in phpMyAdmin and info is correct... so don't have a clue...
It 'taint rocket science and a simple installation shouldn't be this difficult (just an observation :-) ) All this to get a chance to eval. what is supposedly THE PREMIER CMS/Groupware/etc. pkg
Frustrated so thanking u in advance :-)
Haro-san rolleyes

posts: 1560

Hello Haro-san,

I cannot say what is the problem on your local machine.

I am installing Tiki frequently on different machines aswell via FTP as via SHH/SVN.

On Ubuntu 14.04 XAMPP I just recently installed again, but Windows7 + XAMPP is ages ago.

If you go to your tiki root (installation directory) you should find a folder /db and there a file local.php (so /db/local.php).

It mightbe, that for whatever reason the installer on your local machine does not create this file or you have a specific databas location (ex: maybe use of socket instead of stand localhost) ...

I past a template for alocal.php for you, which you might put into the /db directory manually and change the data to your needs:

Edit:
Please mind, that the CKE WYSIWYG has some problems and the following two lines are NOT contained in the code I want to show you for copy/paste:

Edit the 2nd:
CKE is "eating stuff" and braking parts of my post, aka deleting parts!

Since hours I try to provide you a proper CODE to copy/paste, but CKE brings me nearly to freak out and I cannot even deactivate CKE, as another Admins collegue here frequently reactivates.

Anyway, you have been sorting the issue out, as you have seen the temporarily visible CODE and realised the wrong first two lines, added by the CKE.

The rest, regarding the situation here, I will sort out with my Admins collegues and I am in close contact with the developer of wikiLingo, which should eventually replace the CKE based WYSIWYG, with the more stable and robust new approach.

Cheers, sorry for confusion and thanks for patience,
Torsten

posts: 3 USA

Tried local.php above changing info in 1st section and uncommenting adob... got fatal error... had to change upper 2 lines to "less than + question mark + php" and recomment adob to run... but same connect problem

FYI: note found intall.ini.dist in /db, uncommented lines for local file and renamed to install.ini

posts: 3 USA

setup new administrative user and it worked... next I'll figure out how to delete users... tomorrow smile

Amazing what a little sleep can accomplish